Suzuki Volusia Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #1
Why is it that I still have some mild gurgling and popping when I'm slow riding. When I'm decelling from highway speeds, the C50 has a good "Jake brake" sound. When splitting lanes at about 35 mph or so, I get that intermittent popping. I have an Fi2000 w/ Cobra drags. No other air cleaner mods, although I am going to a hypercharge or tornado.

I ask because most of you (the few that do post your Fi2000 settings) say you either leave the settings it comes with or have only made minor adjustments. Mine is currently at 5, 5, 3.5
I've done alot of searches, and getting a large pool of people posting what their Fi2000 settings are is like pulling teeth....like it's some big secret or something. I'm just curious so I can get some idea of when my "green" adjustment is too high.

I don't have an exhaust leak. I did purchase the de-pair kit. Will this left over popping go away, as it appears everyone elses has? Or do y'all have any other ideas.Thx
 

·
Registered
Joined
·
1,428 Posts
I have COBRA 2'' Drags w/ Big City Thunder Monster Baffles, and the FI2000... I still have the FI2000 at the stock setting... I am getting the popping and gurgling sound on decel... but other then that I am not having a problem... Don't hear much of it at cruising speed... I will try it more on the way home tonight and will let you know... Maybe I am not hearing it because I am not listening for it...

BIG CITY THUNDER MONSTER BAFFLES ARE AWESOME!!! HIGHLY RECOMMEND!!!

Ron

BE SAFE
 

·
Registered
Joined
·
54 Posts
I have Jardine 2-1, K&N, and Cobra FI 2000, settings 5,6.5,6. At certain "in between throttle," I have 'almost' a miss. I thought that this was where the"pots" split. I have drilled 3 3/4" holes in air box. At certain low steady rpm I have slight, very occasional popping. Thought it was normal, maybe not.
Hope others will post, maybe everyone has same symptoms.
 

·
Registered
Joined
·
14 Posts
Hi Jackbullet38,
You said that the O2 sensor needed to be bypassed.
The O2 sensor is in the exhaust.
How do you manage that then ?
Cheers,
Jeff.
 

·
Registered
Joined
·
54 Posts
I don't know HOW you bypass the O2 sensor but the guy who installed my vance&hines cruzers did it.....vance&hines reccomend this to be done. I just can't tell you how to do it....sorry.
 

·
Registered
Joined
·
2,212 Posts
jackbullet38 said:
I don't know HOW you bypass the O2 sensor but the guy who installed my vance&hines cruzers did it.....vance&hines reccomend this to be done. I just can't tell you how to do it....sorry.
I believe the C50 only has one O2 sensor, and that is in the intake.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #11
Is the O2 sensor (on the C50) that electronic gizmo that plugs into the back of the air breather housing with the little probe that actually pokes into the air breather area?
 
1 - 12 of 12 Posts
Top