Suzuki Volusia Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 04 Volusia that ran fine but needed a new air filter. So put in new Bikemaster af only thing I changed now it runs rough and feels real cold blooded on start up. Goes to a certain rpm then feels like it runs out of gas missing and popping. Shift to next gear and it pulls again.Only thing changed was the filter.The holes on the filter seemed like loose fit so I put o-rings on to try to get a better seal and seemed to help some.The filter looks like it seals good.Not sure what I am missing.:idea: Any ideas.
 

·
Registered
Joined
·
272 Posts
The first thing I'd do is put the old filter back on as see if the problem goes away. That would confirm it's the new air filter.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Thank you all for your advice but, unfortunatly I've already thrown out the old filter before I went for a ride and noticed the problem.Does anyone know of any other way to find out how and what to test and where to look for other possible vacuum leaks that could be the problem?Or other things that might be causing this problem to help me troubleshoot my bike?
 

·
Registered
Joined
·
1,945 Posts
Bikemaster Air Filters are similar to K&N Air Filters and when installed in a non FI Volusia will require Re-jetting. When I installed a K&N filter in my C50 the FI Computer adjusted to the change in air flow but I have consistently read with the carb pre 2005 Volusia you have to re-jet. It's easier to just buy an OEM filter for your Volusia But a re-jet matched to your high flow filter should provide a little more power at the cost of a few MPG.
 

·
Registered
Joined
·
272 Posts
What 03volusiarider and beezer said above...you're running lean because, from the BikeMaster Air Filter product description:

BikeMaster Air Filters increase air flow when compared to the stock filter. Precision woven #304 stainless steel outer screen construction.These filters are corrosion resistant, washable, reuseable and will last the lifetime of your machine with proper care.

You're running lean. You'll need an OEM filter or rejet since the '04 has carbs.
 

·
Registered
Joined
·
3,872 Posts
Thank you all for your advice but, unfortunatly I've already thrown out the old filter before I went for a ride and noticed the problem.Does anyone know of any other way to find out how and what to test and where to look for other possible vacuum leaks that could be the problem?Or other things that might be causing this problem to help me troubleshoot my bike?
I have a stock air filter..
 

·
Registered
Joined
·
3 Posts
Discussion Starter #10
I have a 04 Volusia that ran fine but needed a new air filter. So put in new Bikemaster af only thing I changed now it runs rough and feels real cold blooded on start up. Goes to a certain rpm then feels like it runs out of gas missing and popping. Shift to next gear and it pulls again.Only thing changed was the filter.The holes on the filter seemed like loose fit so I put o-rings on to try to get a better seal and seemed to help some.The filter looks like it seals good.Not sure what I am missing.:idea: Any ideas.
It has Vance&Hines pipes on it and has been rejeted. Inside of exhaust tips were black ,carbon build it looks like it was running rich,so I cleaned them out back to chrome finish.Wanted to see if the filter leaned the fuel mix.Looked at them just now and they are blacking up already after only a few miles maybe 5 or 6 miles.Going to drain carb and pull float bowl to check for dirt.And check the plugs,they only have have about 500 miles on them.I"ll let you know what I find.On my way to check,thanks for the ideas.
 
1 - 10 of 10 Posts
Top