Suzuki Volusia Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
so recently purchased 07 C50 T, had new tires put on at authorized dealer, notice rear brake plate has a gap in the rear kinda offset , brakes are fine but is this normal ?
 

·
Registered
Joined
·
4,657 Posts
so recently purchased 07 C50 T, had new tires put on at authorized dealer, notice rear brake plate has a gap in the rear kinda offset , brakes are fine but is this normal ?
Got a picture?
It helps a ton on questions like these.
 

·
Super Moderator
Joined
·
4,290 Posts
First post needs a hearty welcome! Hearty welcome bro!
Congrats on the Bully...We likey Pictures!
 

·
Registered
Joined
·
4,657 Posts
Generally speaking, most people won't answer a noobs question before they tell us how cool we all are, and what a great forum this is. ;)

Welcome.
 

·
Registered
Joined
·
4,657 Posts
Um, yeah.
It could be the pic, or maybe the lighting, but that doesn't quite look right to me.
The plate appears bent.

I could be wrong.

I had to click through the pic a few times to get it up to a viewable size.

Here it is blown up a bit.
 

Attachments

·
Registered
Joined
·
4,657 Posts

·
Registered
Joined
·
30 Posts
yep normal.i thought mine was bent as well until i went on ebay and looked at other ones.tricky research will get u just about any info u need lol.welcome from TN :)
 

·
Registered
Joined
·
858 Posts
Looked at the picture several times and from what i remember on my 2007 boulevard, it looked exactly the same. Do not have my bike anymore as i decided to retire from riding at almost 82. Have had the wheel and drive including the brake off many a time over all the years when lubing the drive and yes it always looked the same to me after assembling. So i would not worry, but if you are concerned then drive over to your nearest Suzuki dealer and have them take a look. Or you may know someone else that has a boulevard C50. Take care.


Henry
 

·
Registered
Joined
·
5 Posts
Discussion Starter #16
So thanks everyone, from what I heard looks like this plate is normal, I called and e-mailed dealer but got no response back which does not surprise me after having bike serviced, bike came back with grease marks all over my bike, permanent stained turn signal from spilled brake fluid I had changed and more, what ever happened to pride in work and this is a dealer, glad I joined this site to get some straight answers. Thanks
 
1 - 16 of 16 Posts
Top