Suzuki Volusia Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
224 Posts
Discussion Starter #1
Last night I went to fire up my 07 c50t. I turned the key, everything lit up as usual. I raised the kick stand and nothing. No fuel pump prime...no start... I fiddled with the key and put the kick stand up and down a few times. Still nothing. About the time I was giving up I tried once more and it primed and started. Anyone have this happen? Fix? Thanks, Jeff
 

·
Registered
Joined
·
1,522 Posts
jthorn322 said:
Last night I went to fire up my 07 c50t. I turned the key, everything lit up as usual. I raised the kick stand and nothing. No fuel pump prime...no start... I fiddled with the key and put the kick stand up and down a few times. Still nothing. About the time I was giving up I tried once more and it primed and started. Anyone have this happen? Fix? Thanks, Jeff
Okay, kickstand is up. What about the clutch and shifter? Is the clutch in? Is the bike in neutral? Could be a faulty clutch switch,neutral safety switch, or kickstand switch.
 

·
Registered
Joined
·
224 Posts
Discussion Starter #4
As usual, clutch in, key on, kickstand up, in 1st gear. Speedo lights up. all normal except for no fuel pump priming and no crank with starter button. I'll try to clean and oil stand and stand kill switch.
 

·
Registered
Joined
·
1,522 Posts
jthorn322 said:
As usual, clutch in, key on, kickstand up, in 1st gear. Speedo lights up. all normal except for no fuel pump priming and no crank with starter button. I'll try to clean and oil stand and stand kill switch.
If you have the clutch in, but are in gear, a faulty clutch switch could cause this problem. Try starting it in neutral. If it runs, it's the clutch switch. If you get the green light for neutral in the speedo cluster, and it still won't run, look to the kickstand switch. It should start in neutral, even if the stand is down. I always start mine that way. The only other thing it could be is the kill switch on the right handlebar.
 

·
Registered
Joined
·
224 Posts
Discussion Starter #6
That makes sense. If I start in nuetral and kickstand up, then shift to first and it dies, it would be the kickstand switch, right?
 

·
Registered
Joined
·
1,522 Posts
jthorn322 said:
That makes sense. If I start in nuetral and kickstand up, then shift to first and it dies, it would be the kickstand switch, right?
Yep, the kickstand switch is your problem. I don't remember which way the switch works with out looking at the manual. I can't do that for another 2 hours or so. But, you might try unplugging the switch. If it won't run with it unplugged, you might try jumping it out with a paper clip, just to verify the problem.
 

·
Registered
Joined
·
359 Posts
On my 05' C50 you still have to pull the clutch lever to start in neutral. Still could be the clutch switch if it is not the kicksatnd switch.
 

·
Registered
Joined
·
4 Posts
Seen this was an old post but hope someone could help me. My 05 Boulevard C50 will shut off going down the road, check comes up on speedo, I pull over and have to put it in neutral for fuel pump to kick back on. Fires right up and idles fine, put it in gear and it shuts off, have to go back to neutral to start. Kick stand or clutch switch?
 

·
Super Moderator
Joined
·
26,936 Posts
You are welcome to start a new thread.

I would bet on the kickstand switch.
 

·
Registered
Joined
·
98 Posts
I'd say so too.
Get someone to hold your bike up, front brake on, and soak the kickstand assembly in wd40 or similar, while working the stand fully out and in for a while. Get it all in the moving parts.
 
1 - 15 of 15 Posts
Top