Suzuki Volusia Forum banner

41 - 60 of 149 Posts

·
Registered
Joined
·
3,062 Posts
ekinnee said:
This needs to be stickied.

There is only one issue with the instructions though. On my '04 the bolt heads are rounded and can't be unscrewed. I guess the ignition has never been replaced.
My '04 was the same way, bolt heads are actually broken off upon assembly. Easy to remove with a left handed drill bit. Once the drill bites the screw it will unthread with the drill. Two new phillips headed screws will be needed to replace the origionals.
 

·
Registered
Joined
·
38 Posts
Similar Problem, rode to work saturday no Probs, then went to lunch and only tail lights and 4-ways go on. No brake lights, Head lights, horn, gauges/LCD readout, Fuel pump NOTHING!! Checked the 30 amp Main fuse thats good, but nothing is going to my fuse cluster down to the left side of the bike.
I do not think it is my ignition switch because my tail tights go on when I turn the key on. There is a green connector with that goes to the ignition 4 wires Red/Orange/ Brown and a thin orange the red one is hot but so far i do not kwow if the other three are out bound and the red is the only inbound or if the orange should also be hot!!
I replace battery since it was going on 3 years this November and YES I checked my on/off switch on the bars!!
_________________


Followed your instructions, 4 hrs later with a valve adjustment and new plugs. Bike is running again!!
Thanks for the help!!
 

·
Registered
Joined
·
51 Posts
Does this issue/fix apply to '04 Vols, or just the F.I. C50's? I'm hoping so. Turn key dash doesn't light. Battery tests to 12+. I haven't checked if the tail light comes on or the blinkers work, will do that on Monday when I get back to the bike at work. Would just like to know if the fix laid out here applies to the carb'd Vol.

After 7+ years and 33,450+/- miles, the Princess said no to me for the first time ever...



... the filthy b!tch.
 

·
Registered
Joined
·
1,659 Posts
Thanks for this info... now, maybe I can get it fixed.
 

·
Registered
Joined
·
137 Posts
My 2005 C50 turned 36,000 miles last week. It's my daily rider and has never given me an issue. This week though, twice I had the whole "turned the key and absolutely nothing" episode. Some jostling around and it fired up.

I decided to do my normal research here and the discussion about the recall prompted me to contact my dealer (Lincoln Power Sports in Moscow Mills, MO - Can't say enough good things). I suspected the wiring would be fine, but thought while they had everything taken apart at the manufacturers expense, I'd ask them to charge me whatever time it would take them to do what the OP of this thread discussed.

Sure enough, wires and switch were fine.

They charged me $40 to disassemble the switch, clean everything out and lube it up.

I thought that was more than fair, and certainly the time I would have taken to start from scratch (removing seat, tank, bib, LED's, etc) would have been a couple of hours.

So net message is this, if you haven't had the recall inspection done, go get it taken care of and work with the shop to go the extra step and clean out your starter switch...assuming it doesn't need to be replaced.
 

·
Registered
Joined
·
18,342 Posts
Oddboy....the ignition switch should be the same for the Vol or C50.

we checked battery, and all fuses & connections...still nothing.

I THOUGHT this was what was causing my issueon my .'..a03 carb'd VOL with 46K miles...a shorted/dirty ignition switch. What my no power, no NOTHING issue was the green connector (the 1st pic in this thread) had a bad pin...so the dealership hardwired around it, and no issues since.

we think it was the hr long torrential rain storm we rode in on our way to TN that caused the issue in that connector...once there, it started 5 or 6 times just fine, then that last time...NOTHING.
 

·
Registered
Joined
·
67 Posts
From what I can see here (and in previous threads about the 'sub standard' Suzuki Ignition switch.
It is a Very Good idea (if you run a Light Bar) to regularly lubricate and check your Ignition switch - they just aren't designed for the extra current loads of running a Light Bar. :crying:

I bet very few switches have played up (melted) on Vols (without Light Bars) !?

Just my 2 cents
 

·
Registered
Joined
·
2 Posts
Mine started the whole non-responsive thing and my repair shop asked immediately if I use 3rd party key blanks (which I did) as they will eventually render the ignition switch bad. Got new switch but kept the tumbler so didn't have to replace all the locks on gas cap and toolbox, but am now going out for some actual Suzuki key blanks.
 

·
Premium Member
Joined
·
28,859 Posts
Mine started the whole non-responsive thing and my repair shop asked immediately if I use 3rd party key blanks (which I did) as they will eventually render the ignition switch bad. Got new switch but kept the tumbler so didn't have to replace all the locks on gas cap and toolbox, but am now going out for some actual Suzuki key blanks.
I'd say pucker really really hard 'cause your repair shop is attempting to blow smoke in the vicinity of your rectum. The key turns the tumbler and the tumbler makes the contacts. When the switch goes bad, it is the contacts that arc and melt the plastic plate that hold them, nothing to do with a key blank. A periodic lube with dielectric grease will prevent said arcing.
 

·
Administrator
Joined
·
51,648 Posts
This is a handy thread, hence a long overdue sticky issued.
 

·
Registered
Joined
·
10 Posts
Ignition Switch Problem

Hey guys, after having switch failure on my 05 c50t the other day I opened my ignition up and sure enough one contact was completely stuck down & melted. No play in it at all. I was able to get the cluster and lights back however after prying the contact open and reassembling the switch - but I failed to follow directions specifically and unplug the green switch harness beforehand, now I get an Fi error on the odometer and the fuel pump shuts down almost immediately after turning the key, it wont start. I figure the dealership is in my future regardless for a new switch, but was curious if any of you could help me resolve the Fi error based on how it happened (me misplacing my brain).
 

·
Premium Member
Joined
·
28,859 Posts
dvnt, I have the switch that the dealer uses to download the code that the display in your speedo is holding, that fault code will tell the problem with your FI.

I can clear the code, but until you get your switch fixed, I fear it will just throw another code.

And I live in Sioux Falls.
 

·
Registered
Joined
·
3,032 Posts
Hey guys, after having switch failure on my 05 c50t the other day I opened my ignition up and sure enough one contact was completely stuck down & melted. No play in it at all. I was able to get the cluster and lights back however after prying the contact open and reassembling the switch - but I failed to follow directions specifically and unplug the green switch harness beforehand, now I get an Fi error on the odometer and the fuel pump shuts down almost immediately after turning the key, it wont start. I figure the dealership is in my future regardless for a new switch, but was curious if any of you could help me resolve the Fi error based on how it happened (me misplacing my brain).

Check the 30 AMP main fuse.
 

·
Registered
Joined
·
10 Posts
Viper that would be fantastic, just to be able to ride it to the dealer instead of having to tow it. I do have the means to get it there just a bit more of an effort. They said it was still covered under the service recall believe it or not but they said all thats covered is a wire!?Wonder if theres been too much load on it anyway.
 

·
Premium Member
Joined
·
28,859 Posts
Viper that would be fantastic, just to be able to ride it to the dealer instead of having to tow it. I do have the means to get it there just a bit more of an effort. They said it was still covered under the service recall believe it or not but they said all thats covered is a wire!?Wonder if theres been too much load on it anyway.
Yeah, I'm familiar with the recall, I really doubt that is your problem.

I'll shoot you a pm with my phone number.
 
41 - 60 of 149 Posts
Top