Suzuki Volusia Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I put on a set of cobra dragpipes to replace the stock pipes but I didn't see any exhaust rings. I was going to use the original rings. I ordered some off of the internet to put on. I have a 2007 C50T Boulevard and was wondering if anybody has any info on this or how to put the new rings on.
 

·
Registered
Joined
·
18,342 Posts
they're in there, they're 'cardboard' and you may need a screwdriver to pry up an edge to get them out.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
On the engine where they go in or on the end of the pipe? I get the rings today and I am putting them on after work. I want to make sure the old ones are off before I put the new ones on.
 

·
Registered
Joined
·
18,342 Posts
they usually adhere to the engine block.
 

·
Registered
Joined
·
740 Posts
i put on cobra slashcuts, left the original exhaust "gaskets" when i changed. hadnt had any problems, only 500 miles on the new pipes, but no leaks, distortion, etc.

for 6 bucks, it is a good piece of mind to replace them, but not at all necessary if you have a low mileage bike.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
It sounds like I might have some leakage so I want to make sure they are seated good! It might just be the valve noise. I had a GS1000E and it had a lot of noise also.
 

·
Registered
Joined
·
18,342 Posts
cherokee2602 said:
It sounds like I might have some leakage so I want to make sure they are seated good! It might just be the valve noise. I had a GS1000E and it had a lot of noise also.
you'd know it on a VOL if you had exhaust leak!! it would BACKFIRE :shock: especially on deceleration. I don't know re: C50 & fuel inj vs. carb situation.
 
1 - 7 of 7 Posts
Top