Suzuki Volusia Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter #1
07 C50 - 5300 miles. Started shifting kinda hard last sat on a road trip, and got a little harder as time went on. Not terrible, but harder than I was used to. Figured I'd just change the oil, and see if that helped, even though it's only been about 1000 miles. Changed the oil, and now it won't shift into third gear or up most of the time. Every once in a while, it will go to third, then forth and fifth are fine. Downshift again and it won't go back up. Weird thing is, after trying to get into third, I would swear the gearshift is ALL the way up and starts to go down slowly by itself. Really weird.

This is the first time I've ever had maintenance screw something up! Off to the dealer tommorrow, and glad it's under warranty. I just hope I can get it back quick, this is a great time of year to ride up here.

Anyone ever heard of this one? I hope it's not a sign of things to come.
 

·
Registered
Joined
·
959 Posts
tranny clutch

I only had my 05 for a couple months and it wouldnt shift. Turns out there is a small pin inside the clutch area that wasnt installed properly when it was built. I still dont quite understand what it does but the dealer fixed it. Let us know how you make out.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #5
Well, hopefully its simple. I really don't care as long as it gets fixed FAST! Linkage would make sense, but going out after an oil change is weird.
 
1 - 5 of 5 Posts
Top