Suzuki Volusia Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have an 04 VL 1500 and I did some rewiring because the guy bought it from had black to yellow yellow to black purple disc purple that yellow that brown this brown that it was just disgusting. So I went by the color code and everything in this forum in Volusia riders and I did color color color color and I added a couple of lights but I didn't mess with anything all the right colors are the same from front to back in my tail light and signals in the rear. So my brake light is staying on now and when I hit the brakes the brake light dims, now mind you I took it all apart and put it all back together and rewired it through the color codes of the manual also through here. Any ideas why my brake light is staying on and want to hit the brakes the light dims
 

·
Super Moderator
Joined
·
32,937 Posts
Welcome from Kennesaw GA!

First off, I can't believe I'm saying this, but thanks for using the right brake. 🤦‍♂️

Second, I suck at wiring, which is funny since the Air Force used to trust me to work on the electronics in F16s. 😋

That said, it's been a minute, but isn't there a parking light function on the C50? I don't recall how it's activated, but maybe something got crossed up there?

Hang out, I'm far from the smartest here.
 

·
Premium Member
Joined
·
4,141 Posts
If you have a 1500 the wiring may be different than a Volusia 800. We do have some 1500/C90 in the group so someone may have a solution for you. If not, Delphi has a good forum for 1500/C90.
 
  • Like
Reactions: Whiskey
1 - 3 of 3 Posts
Top