Suzuki Volusia Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hello all! Sorry for my grammar(
I have a 2008 Boulevard c50, and for almoust half a year I have a problem with detonation and backfiring. It starts only when the bike is hot, when you try to accelerate fast from low RPMs, you can hear detonation sound from the engine, also sometimes you can hear a pop from the exaust pipe when you ride on middle RPM with no trottle. My pipes and tail light are covered with black soot. I tryed to change the petrol, changed the sparks, air filter, TPS sensor, 3 times I cleaned the injectors, cleaned fuel filters and everything inside my tank. I've tryed octane boosters and fuel injector cleaners, but nothing seems to help. I live in Vietnam, we dont have any qualified mechanics here, so I do it by myself, learning step by step. May be someone can help me? Where to look? What else to check?
 

·
Administrator
Joined
·
52,934 Posts
Try the pair valve disconnect, or removal if proven defective. Suzuki C50 and Volusia are nearly the same set-up.

Volusia Pairvalectomy
 

·
Administrator
Joined
·
52,934 Posts
The pair valve is an anti-pollution/emissions device, which frequently goes bad, causing symptoms very similar to those You are experiencing.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
The pair valve is an anti-pollution/emissions device, which frequently goes bad, causing symptoms very similar to those You are experiencing.
Did it today in the morning. No change, stiil same problems :(
 

·
Administrator
Joined
·
52,934 Posts
Have the valves been adjusted recently?
 

·
Administrator
Joined
·
52,934 Posts
Yes, We did it like in manual. Things got worse after that I think... I have a lot of rust in my tank, I will try to clean it on this week

Did You only turn the crankshaft counter-clockwise, or did You use clockwise motion, when performing the valve adjustment?
 

·
Administrator
Joined
·
52,934 Posts
Next question:
Did You make certain to adjust the front & rear valves on the correct crankshaft rotations?
 

·
Administrator
Joined
·
52,934 Posts
The machine starts/runs, but runs poorly, with backfiring and detonation.
More likely a fuel issue, because an extremely lean fuel condition will cause the problems that You are experiencing.
If the ignition/spark was the issue, the machine would probably not run at all.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #15
The machine starts/runs, but runs poorly, with backfiring and detonation.
More likely a fuel issue, because an extremely lean fuel condition will cause the problems that You are experiencing.
If the ignition/spark was the issue, the machine would probably not run at all.
The main question if it is like this, why it starts only when it is hot?
 

·
Registered
Joined
·
2 Posts
I had a problem with backfiring a few years ago and I believe all I did was install a new air filter. The backfiring only happened for me when the engine was warm. I have a 2003 with carbs instead of fuel injection, so it may be different.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #17
I cleaned all the fuel system again, cleaned the tank and filter, installed new injectors, performance is better, but still same problems, sometimes it backfires on low trottle, has detonation. And sometimes it keeps the engine on high rpm on neutral, like it is cold, but it is not. Any thoughts?
 
1 - 18 of 18 Posts
Top