Suzuki Volusia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Bike was running fine as I was cruising down the road then went to shift into 4th gear and the bike just shut off. No jumping, no puttering, just engine died. I got to the side of the road and gave it a second and after a few tries it cranked back up. The first coule times I put it into first to take off it shut down again then was able to start it and get going. When I got to third gear I think it shut off again. Rinse and repeat a few times till I just hit the back road and babied it in second to get it back home. Ran some seafoam through it and took it around the back roads and everything seemed fine once again. So I went to take it for a ride and it ran great for the first 15 minutes or so then again I went to shift into 4th and it died just the same as before except this time it would crank up then die everytime I went to shift into first. Pushed it off the road and then it wouldn't even turn over. Battery had plenty of juice but couldnt get it started. Went back the next morning to trailer it home and now it does absolutely nothing when turning the key to the on position. No lights no fuel pump no nothing. I am at a loss for what could cause such odd and seemingly unrelated issues. HELP!!!!
 

·
Premium Member
Joined
·
14,449 Posts
Sounds like your kickstand switch or the spring for the kickstand.
If you search here you will see people have had it before.
 

·
Registered
Joined
·
221 Posts
My first two suspects would be the kickstand switch and if that checks out then I would look into the kill switch....
 
1 - 3 of 3 Posts
Top