Suzuki Volusia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
499 Posts
Discussion Starter #1
Hello all,

I have a 2007 Boulevard C50 FI that is having issues. It tends to idle a bit rough, but when I start to go, adding throttle and releasing clutch it will bog down and die. If I'm real careful and feather both I can get it going, but if I add to much throttle (not gunning it, just normal) it will bog down and die. If I do get it going down then road in second or third gear it surges very badly at a constant throttle setting.

I had a mechanic look at it and he thought it might be one of the intake air pressure sensors, but wasn't willing to guess since a new one (there are two) from Suzuki is $250. I found a third party one and a used one and swapped them out. No change. The spark plugs have been changed, no help. The air filter did appear pretty dirty so I swapped it out, no change. I've checked the voltages/resistances for the fuel injectors and they are normal. Took off the air intake and didn't see any cracks or damage.

I am at the limits of my knowledge at this point. It's been a great bike until this season. Anyone have any ideas? What could be wrong, what I need to look at next?

Thanks in advance.
 

·
Registered
Joined
·
19,604 Posts
To run properly, you need air, fuel compression and spark. You don't state how many miles are on the bike, or whether you have ever performed a compression test, or adjusted the valve clearance, so I would start there then move to other causes. If the compression is good and your valve clearance checks out, my guess is you are experiencing a fueling issue, either with fuel pressure from the pump itself, or from the fuel injectors. Those can all be removed and tested individually.
 

·
Registered
Joined
·
499 Posts
Discussion Starter #3
To run properly, you need air, fuel compression and spark. You don't state how many miles are on the bike, or whether you have ever performed a compression test, or adjusted the valve clearance, so I would start there then move to other causes. If the compression is good and your valve clearance checks out, my guess is you are experiencing a fueling issue, either with fuel pressure from the pump itself, or from the fuel injectors. Those can all be removed and tested individually.
It's got about 17k miles on it. I will see about checking the compression and valve clearances.

Thanks.
 
1 - 3 of 3 Posts
Top