Suzuki Volusia Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hi
i am new to this page and desperately looking for help, i got used 2003 vl 800 and at t hat time bike had 18345 km on it and was running ok at least i was thinking that bike dosent have problems but after oil change after i added 4k on it my bike clutch was weird and then when i rode the bike i got red oil light coming on for sec or 2 and then bike would die so i started again and got home and decided to check the oil, after i drained oil out i can smell gasoline in it so some of my friends told me that is mine jets so i ordered kit and i put 142 in it and adjusted mix screw to 2.5 turns bibe was running smooth then i let the bike sit for 2 weeks and same problem happen 1st i notice my fuel gage shows that gas is missing and then when i try to ride same problem come clutch was low, oil light come again for sec and then the bike died so i get bike home parked and have no clue what could be is it myb engine problem or what possible could be please if anyone had same problem and can share what is done i would greatly appreciate.. sorry for my broken eng writing
 

·
Registered
Joined
·
1,725 Posts
my fuel gage shows that gas is missing .......
to check the oil, after i drained oil out i can smell gasoline i
Sounds like you need to service the float needle and seal to me (flooding) and maybe have a leak in the petcock.

I hate to ask, but, motorcycle oil or automobile oil? Anti-wear additives in car oil can ruin the clutch.
 

·
Super Moderator
Joined
·
26,437 Posts
Welcome from Kennesaw GA!
 
1 - 3 of 3 Posts
Top