I need help please. - Suzuki Volusia Forums : Intruder Volusia and Boulevard Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 09-01-2019, 03:26 PM Thread Starter
New Member
 
Join Date: Sep 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
I need help please.

Greetings. I have a 2006 Suzuki Boulevard C50 and now it has a fault that seems to me to be the fuel / injection system, with difficulty it runs between 30-50 mph and when accelerating it tends to drown and even shut down. Any help you can offer me, I thank you very much.
FirefighterRider is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-01-2019, 03:32 PM
Administrator

 
Capt Cruiser's Avatar
 
Join Date: Mar 2006
Location: Ludlow, MA
Posts: 16,070
Thanks: 822
Thanked 2,647 Times in 1,550 Posts
Garage
A little more history. It has been running fine and this just started to happen? Or had this been an ongoing problem?

When's the last time you got gas?
Capt Cruiser is online now  
post #3 of 5 (permalink) Old 09-01-2019, 03:45 PM
Super Moderator

 
duglaura's Avatar
 
Join Date: Jun 2005
Location: Gettysburg, Pa
Posts: 4,031
Thanks: 547
Thanked 1,022 Times in 697 Posts
Garage
First post needs a hearty welcome...Hearty Welcome!


Live to ride, ride forever! We support our troops! God Bless Them.
Pa/Md/WV ABATE member
2005' C50T (sold)
2004' FLHTI/HD Electra Glide w/huge chrome wheels.

duglaura
duglaura is offline  
 
post #4 of 5 (permalink) Old 09-01-2019, 04:42 PM
Super Moderator

 
DCinCT's Avatar
 
Join Date: Oct 2004
Location: Ct,Columbia
Posts: 18,879
Thanks: 1,980
Thanked 3,253 Times in 2,106 Posts
could have picked up some bad gas.....if this did start up after your last gas fill...dump the old gas out, run some seafoam thru it,,,throw about 3/4 ounces in your tank and fill it up.Good luck...hope fully some others will come along and offer other suggestions.

Whats the big hurry...slow down and enjoy the ride!

DCinCT is offline  
post #5 of 5 (permalink) Old 09-01-2019, 04:52 PM
Super Moderator
 
Whiskey's Avatar
 
Join Date: Nov 2012
Location: Kennesaw, GA
Posts: 21,769
Thanks: 1,511
Thanked 1,713 Times in 1,300 Posts
Garage
Welcome from Kennesaw GA!


I'll second the history request and the bad gas suggestions both. What you're describing sounds a lot like bad gas. Did you just buy the bike? Did you just recently fill it up? Could be a bad fuel pump, but I would suspect the gas first.

Music, Motorcycles, and Family... Nothing else really matters in life!

2005 Boulevard M50 (DOA)
2006 Boulevard C50 (retired)
2000 BMW R1100RT
2017 KTM Duke 390

Whiskey is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki Volusia Forums : Intruder Volusia and Boulevard Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome