S50 VS800 Marauder - Suzuki Volusia Forums : Intruder Volusia and Boulevard Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 08-09-2019, 01:38 PM Thread Starter
New Member
 
Join Date: Aug 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
S50 VS800 Marauder

[SIZE="a"]First time here so hello everyone. So, I bought a 2008 Suzuki VS800 S50 recently. Only 3500 miles and had been sitting. Gave the carbs a good cleaning along with a K&L rebuild kit. Rear carburetor seems to do fine but front carb pops/backfires quite a bit when I give it gas. Mostly low rpm's. All cables to the carbs were disconnected without marking where they should go back. So, could this be a carb sync problem (I see there is a cable running from 1 to the other) or maybe even a pair valve? At my wits end and any suggestions would be appreciated.
Thanks in advance.[/SIZE]
Turbofied is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki Volusia Forums : Intruder Volusia and Boulevard Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome