Speedo rattling - Suzuki Volusia Forums : Intruder Volusia and Boulevard Forum
LinkBack Thread Tools
post #1 of 5 (permalink) Old 12-06-2012, 03:06 PM Thread Starter
Junior Member
Join Date: Nov 2012
Location: New York
Posts: 27
Thanks: 1
Thanked 3 Times in 3 Posts
Speedo rattling

Hey everyone! I've noticed a rattling sound coming from my speedo on my 06 c50. Does anyone know of a quick and inexpensive way to fix this? It doesn't interfere with the bike at all and it's been happening since I purchased it used back in June, but recently it's just been driving me crazy! It seems like its the glass on the speedo thats just a bit loose, but i've noticed that the whole circular assembly (not the mount itself) rattles a bit when I start it up. Any help with this would be much appreciated!
Diego.Andrade is offline  
Sponsored Links
post #2 of 5 (permalink) Old 12-06-2012, 04:59 PM
Senior VR Member
dewey405's Avatar
Join Date: Aug 2009
Location: Moore, Oklahoma
Posts: 784
Thanks: 42
Thanked 100 Times in 50 Posts
I would pull the chrome housing off (1 bolt IIRC) and check the actual gauge mounts inside, mine had 2 of the 3 broken inside and was causing a rattling.

2009 C50 SE(Grey/Dark Grey) 2009-2012
2012 Vulcan 1700 Nomad

dewey405 is offline  
post #3 of 5 (permalink) Old 12-06-2012, 08:42 PM
Senior VR Member
03volusiarider's Avatar
Join Date: Aug 2010
Location: Duffield,VA
Posts: 3,843
Thanks: 250
Thanked 720 Times in 642 Posts
Or you could put a tank bib on your bike that goes under the gauges.

03volusiarider is offline  
post #4 of 5 (permalink) Old 12-07-2012, 04:11 AM
VR Member
Join Date: Sep 2012
Posts: 158
Thanks: 35
Thanked 16 Times in 13 Posts
There are 2 plastic catches where u mount the speedo then tighten the screw. See if any are broken. If not, use rubber washers on the two plastic mounts. Then pull the mount so it aligns with the screw and then tighten it. Tht will mount the speedo casing tight.

Sent from my iPad using MO Free
Againstallodds is offline  
post #5 of 5 (permalink) Old 12-10-2012, 03:52 PM
VR Member
azglocker's Avatar
Join Date: May 2012
Posts: 95
Thanks: 0
Thanked 16 Times in 9 Posts
I glued down the metal ring around the glass to stop mine. It had some double stick tape on it, but that wasn't enough.
azglocker is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Suzuki Volusia Forums : Intruder Volusia and Boulevard Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome