Speedo rattling - Suzuki Volusia Forums : Intruder Volusia and Boulevard Forum

Reply
 
LinkBack Thread Tools
Old 12-06-2012, 04:06 PM   #1 (permalink)
Junior Member
 
Join Date: Nov 2012
Location: New York
Posts: 27
Thanks: 1
Thanked 3 Times in 3 Posts
Default Speedo rattling

Hey everyone! I've noticed a rattling sound coming from my speedo on my 06 c50. Does anyone know of a quick and inexpensive way to fix this? It doesn't interfere with the bike at all and it's been happening since I purchased it used back in June, but recently it's just been driving me crazy! It seems like its the glass on the speedo thats just a bit loose, but i've noticed that the whole circular assembly (not the mount itself) rattles a bit when I start it up. Any help with this would be much appreciated!
Diego.Andrade is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-06-2012, 05:59 PM   #2 (permalink)
Senior VR Member
 
Join Date: Aug 2009
Location: Moore, Oklahoma
Posts: 784
Thanks: 42
Thanked 100 Times in 50 Posts
Default

I would pull the chrome housing off (1 bolt IIRC) and check the actual gauge mounts inside, mine had 2 of the 3 broken inside and was causing a rattling.
__________________
2009 C50 SE(Grey/Dark Grey) 2009-2012
2012 Vulcan 1700 Nomad


dewey405 is offline   Reply With Quote
Old 12-06-2012, 09:42 PM   #3 (permalink)
Senior VR Member
 
Join Date: Aug 2010
Location: Duffield,VA
Posts: 3,243
Thanks: 207
Thanked 593 Times in 533 Posts
Garage
Default

Or you could put a tank bib on your bike that goes under the gauges.
__________________
03volusiarider is offline   Reply With Quote
Old 12-07-2012, 05:11 AM   #4 (permalink)
VR Member
 
Join Date: Sep 2012
Posts: 158
Thanks: 35
Thanked 16 Times in 13 Posts
Garage
Default

There are 2 plastic catches where u mount the speedo then tighten the screw. See if any are broken. If not, use rubber washers on the two plastic mounts. Then pull the mount so it aligns with the screw and then tighten it. Tht will mount the speedo casing tight.


Sent from my iPad using MO Free
Againstallodds is offline   Reply With Quote
Old 12-10-2012, 04:52 PM   #5 (permalink)
VR Member
 
Join Date: May 2012
Posts: 95
Thanks: 0
Thanked 16 Times in 9 Posts
Default

I glued down the metal ring around the glass to stop mine. It had some double stick tape on it, but that wasn't enough.
azglocker is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:19 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum