FREE - Perfect your clutch, with manual page... - Page 14 - Suzuki Volusia Forums : Intruder Volusia and Boulevard Forum
 3Likes
Reply
 
LinkBack Thread Tools
post #131 of 134 (permalink) Old 02-02-2015, 12:29 AM
FPS
Senior VR Member
 
FPS's Avatar
 
Join Date: Jul 2007
Location: San Diego, CA
Posts: 7,102
Thanks: 96
Thanked 281 Times in 221 Posts
That's exaclty it. Thank you. Confirms I was doing it right and have a ligitimate issue.

Quote:
Originally Posted by kydragonrider
I've owned my 2006 C50T for a year now and was totally satisfied with it until I joined this site.
Quote:
Originally Posted by rodie1200 View Post
It's not what you ride, but if your wife will let you ride
FPS is offline  
Sponsored Links
Advertisement
 
post #132 of 134 (permalink) Old 02-02-2015, 01:01 AM
Senior VR Member
 
Sleepwalker's Avatar
 
Join Date: Oct 2014
Location: Lynchburg, VA.
Posts: 1,095
Thanks: 346
Thanked 287 Times in 251 Posts
Garage
Hope it all works out, glad i was able to help a bit.


2014 C50T
Member of the Iron Horse Cavalry/ABATE of Virginia

"The more I learn, the more I realize I donít know."
ó Albert Einstein
Sleepwalker is offline  
post #133 of 134 (permalink) Old 06-02-2015, 12:27 AM
VR Member
 
daprez1963's Avatar
 
Join Date: Oct 2014
Location: Florida
Posts: 236
Thanks: 0
Thanked 7 Times in 7 Posts
quick question...so I replaced my clutch springs and plates...having to remove exhaust pipes, covers etc...did the job with ease...replaced everything, filled back up with oil...adjusted cable etc...then took for ride...runs nice...but...
I had not noticed this before but now I hear a slight sound occasionally while in gear going down street...it sounds like keys jingling...it is coming from the same side of the clutch basket...I can't make out exactly where because its not constant...I have double checked all bolts and nothing is loose, no rattling due to vibration...I can not figure out what it is but since I had just done clutch, I am concerned I didn't do something right or didnt tighten springs enough or left my watch in the clutch assembly....
Does anyone have any clue what that noise might be...right side middle bike sounds like keys and is not contant...thanks
daprez1963 is offline  
 
post #134 of 134 (permalink) Old 07-24-2016, 12:22 AM
Junior Member
 
Join Date: Nov 2015
Location: Sacramento Co.
Posts: 31
Thanks: 2
Thanked 2 Times in 1 Post
Wow, thanks IronMan.
I had a slight slip that I noticed starting on the 03 vl800 I'm working on. Took all the side covers off and followed your advice. Cleaned and lubed any and everything---even washed out grime that had been hidden under half the bike.
Test drove after adjustment and later made a further tweak. Test drove again and discovered everything remarkably smooth, with no slip at all. Major difference in shifting resistance and noise. Buttoned it back up--good to go!
gemicka1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Suzuki Volusia Forums : Intruder Volusia and Boulevard Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome